Number: 1592
Title: xlinks do not work in SVG
Submitter: phil colbourn
Date: Wed Mar 4 16:31:54 2009
Subsys: Dot
Version: 1.16
System: x86-OSX-10.5.6
Severity: minor
Problem:
command: dot -v -Tsvg -o core-a1.dot.svg core-a1.dot

output:
dot: fontname=helvetica fontpath=[internal arial]
network simplex: 1 nodes 0 edges 0 iter 0.00 sec
network simplex: 5 nodes 4 edges 0 iter 0.00 sec
mincross: pass 0 iter 0 trying 0 cur_cross 0 best_cross 0
mincross: pass 2 iter 0 trying 0 cur_cross 0 best_cross 0
mincross: pass 2 iter 0 trying 0 cur_cross 0 best_cross 0
mincross core-a1: 0 crossings, 0.00 secs.
network simplex: 13 nodes 16 edges 1 iter 0.00 sec
routesplines: 2 edges, 28 boxes, 0 splines 0.00 sec

All works except that the headURL links don't work in firefox 3.01, safari Version 4 Public Beta (5528.16)

The links work with this script: dot -v -Tcmapx -o core-a1.dot.map -Tpng -o core-a1.dot.png core-a1.dot

cat <<EOF > core-a1.dot.html <HTML VERSION="2.0" xmlns:xlink="http://www.w3.org/1999/xlink"

>>

<HEAD> <TITLE>OCDN Core A1</TITLE> </HEAD> <BODY bgcolor="#f0f0f0" background1="sydneyBackground.png"> <H1 align=CENTER>OCDN</H1> <CENTER><IMG SRC="core-a1.dot.png" usemap="#core-a1"/></CENTER> EOF

#FIXME: make into a template too cat core-a1.dot.map >> core-a1.dot.html echo "</BODY></HTML>" >> core-a1.dot.html


Input file: b1592.dot
Output file: b1592.svg
Comments:
the links do not work in Graphvix.app Version 2.21 (2.21.20090303.0545).

Although, i thought they did work in 2.20.3
Owner: *
Status: *