Number: 1221
Title: Won't install on Centos 4.3
Submitter: John Ernst
Date: Thu Nov 1 19:58:20 2007
Subsys: Dot
Version: FC8.i386 graphviz-2.14.1-1.fc8.i386.rpm
System: x86-Linux-Centos 4.3
Severity: minor
Problem: Is there a version of graphviz that installs on centos 4.3?
Comments:
[ellson] Does the .el4 version from www.graphviz.org not work for you? It was built on centos4.5.

Its a single source rpm for all Redhat-based distributions, so you should be able to do:

rpmbuild --rebuild graphviz-2.14.1-1.src.rpm

[ernst] I typed "rpmbuild --rebuild graphviz-2.14.1-1.fc8.i386.rpm

And got


Error: source package expected, binary found
Error:          graphviz-2.14.1-1.fc8.i386.rpm
Cannot be installed

[ellson] Use the .src.rpm

[ernst] Thanks, that worked foer the build. I have rebuilt. I went to:

/usr/src/redhat/RPMS/i386 and typed "rpm --install graphviz-2.14.1-1.-i386.rpm"

And got a bunch of messages to the effect of:

"File xxx from install of 2.14.1-1 conflicts with file from package 2.8-1"

[ellson] Either uninstall graphviz-2.8 before installing graphviz-2.14.1:


   rpm -e `rpm -qa | grep graphviz`
   rpm -ivh graphviz*rpm

or upgrade the rpms instead of installing:


   rpm -Uvh graphviz*rpm

Owner: ellson
Status: *