Number: 1119
Title: Missing layout plugins
Submitter: Suresh
Date: Fri Apr 13 17:30:58 2007
Subsys: Dot
Version: 2.12
System: x86-Linux-RHEL 4.0
Severity: critical
Problem:
Hi

We are facing some issues with the graphviz application.

Please find below the graphviz (http://graphviz.org ) application error message.

===========================


[root@saravana_graph tmp]# dot -Tpic 1.dot 1.ps
Error: 1.dot:4: syntax error near line 4
context: node28 -> >>> {node29, <<< node30,node31};
Error: Layout was not done. Missing layout plugins?
Error: Layout was not done. Missing layout plugins?
Error: dot: can't open 1.ps

Input File digraph G { a -> b; a -> x -> y -> z; node28 -> {node29,node30,node31}; }
Comments:
[erg] There are 3 problems here. First, there is the syntax error. Nodes in a subgraph do not use comma separators, so your graph should just have

node28 -> {node29,node30,node31};

Second, in the command

dot -Tpic 1.dot 1.ps

is 1.ps meant to be the output file? If so, you need to use -o 1.ps. Also, if the .ps subscript implies this is a postscript file, the appropriate -T option is -Tps.

Third, it appears the config file for the graphviz plugins has not be created. This would cause the message

Error: Layout was not done. Missing layout plugins?

The simplest thing to try is running dot -c. This should create the file graphviz/config under the library directory used for installation. Normally, this is done when you run

make install.
Owner: *
Status: *